LACP configuration 2

Topology

Tasks:

A data center requires a redundant and high-bandwidth connection between two switches (SW1 and SW2). To achieve this, you are tasked with creating an EtherChannel. IP connectivity has already been established.

  1. On SW1 and SW2, use IEEE 802.3ad link aggregation. Combine Fa0/10 and Fa0/11 into a single logical link with number 45. Both links must negotiate aggregation.
  2. Set the EtherChannel to operate as a trunk link using IEEE 802.1Q tagging.
  3. Allow VLANs 100, 200, and 300 across the trunk link.
  4. Verify that PC1 is capable of pinging PC2.

Solution:

Task 1: On SW1 and SW2, use IEEE 802.3ad link aggregation. Combine Fa0/1 and Fa0/2 into a single logical link with number 10. Both links must negotiate aggregation.

IEEE 802.3ad link aggregation is commonly referred to as LACP (Link Aggregation Control Protocol). LACP uses two modes, 'active' and 'passive' mode. In active mode, a switch actively initiates and negotiates the formation of an EtherChannel by sending LACP packets to its counterpart. In passive mode, a switch listens for LACP packets but does not actively initiate the negotiation. At least one end of the link must be configured in active mode for LACP to form an EtherChannel.

As both links must negotiate aggregation, both side must be in active mode.

On SW1:

SW1#configure terminal
SW1(config)#interface range f0/10-11
SW1(config-if-range)#channel-group 45 mode active
SW1(config-if-range)#exit

On SW2:

SW2#configure terminal
SW2(config)#interface range f0/10-11
SW2(config-if-range)#channel-group 45 mode active
SW2(config-if-range)#exit

The interface range f0/1-3 command allows us to configure the interfaces collectively which can save a lot of time. channel-group 45 mode active enables LACP in active mode on interfaces FastEthernet0/1 and FastEthernet0/2 and assigns them to EtherChannel group 45.

 

Task 2: Set the EtherChannel to operate as a trunk link using IEEE 802.1Q tagging.

To configure the etherchannel we created, we need to use the interface port-channel 45 command. Remember that etherchannel in Cisco IOS is sometimes also called channel-group and port-channel.

On SW1:

SW1(config)#interface port-channel 45
SW1(config-if)#switchport trunk encapsulation dot1q
SW1(config-if)#switchport mode trunk

On SW2:

SW2(config)#interface port-channel 45
SW2(config-if)#switchport trunk encapsulation dot1q
SW2(config-if)#switchport mode trunk

switchport trunk encapsulation dot1q specifies the use of IEEE 802.1Q for VLAN taggingswitchport mode trunk configures the EtherChannel as a trunk link.

 

Task 3: Allow VLANs 100, 200, and 300 across the trunk link.

On SW1:

SW1(config-if)#switchport trunk allowed vlan 100,200,300

On SW2:

SW1(config-if)#switchport trunk allowed vlan 100,200,300

 

Task 4: Verify that PC1 is capable of pinging PC2.

PC1:\> ping 192.168.100.2

Pinging 192.168.100.2 with 32 bytes of data:

Request timed out.

Reply from 192.168.100.2: bytes=32 time=26ms TTL=115

Reply from 192.168.100.2: bytes=32 time=24ms TTL=115

Reply from 192.168.100.2: bytes=32 time=25ms TTL=115

Now exit the configuration mode and save the configuration.

SW1(config)#end
SW1#write memory

SW2(config)#end
SW2#write memory

 

Packet Tracer File

Clicking this button will begin the download of a ZIP file. Inside the ZIP file, you'll find a Packet Tracer Activity (.pka) file, which will automatically track your progress as you configure the network.