IPv4 and IPv6 Addressing 2

Topology

Tasks:

Refer to the topology. All physical cabling is in place and verified. A company plans to deploy 16 new sites. The sites will utilize both IPv4 and IPv6 networks.

Task 1: Subnet the network 172.16.0.0/16 to meet the following subnet requirements and maximize the number of hosts:

  • Use the third subnet to assign IPv4 addresses.
  • Assign the first usable IP address to Fa0/0 on Router R1.
  • Assign the last usable IP address to Fa0/0 on Router R2.

Task 2: Use the network 2001:db8:abcd::/64 for IPv6 addressing and meet the following requirements:

  • Assign an IPv6 GUA using a unique 64-bit interface identifier to Fa0/0 on Router R1.
  • Assign an IPv6 GUA using a unique 64-bit interface identifier to Fa0/0 on Router R2.

Solution:

Task #1

Given the network 172.16.0.0/16, we need to use the third subnet and assign the first and last usable IP addresses to Router R1 and R2, respectively.

To deploy 16 new sites we need to make 16 subnets. This means we need to borrow 4 bits as 24 = 16 subnets. On a /16 network, when you borrow 4 more bits, the subnet mask becomes /20.
With an increment value of 16, the subnets will be as under:

172.16.0.0/20      (1st subnet)
172.16.16.0/20     (2nd subnet)
172.16.32.0/20     (3rd subnet)

The range of usable IP addresses for the 3rd subnet is: 172.16.32.1 - 172.16.47.254.

Assign the first usable IP address, 172.16.32.1/20, to Fa0/0 on R1. The subnet mask for /20 prefix is 255.255.240.0

On R1:

R1#configure terminal
R1(config)#interface f0/0
R1(config-if)#ip address 172.16.32.1 255.255.240.0
R1(config-if)#no shut

Assign the last usable IP address, 172.16.47.254/20, to Fa0/0 on R2

On R2:

R2#configure terminal
R2(config)#interface f0/0
R2(config-if)#ip address 172.16.47.254 255.255.240.0
R2(config-if)#no shut

 

Task #2

The network 2001:db8:abcd::/64 is to be used for IPv6 addressing on both routers. GUA stands for Global Unicast Address and unique 64-bit interface identifier means we need to use eui-64 method.

First enable IPv6 on the interfaces an then assign an IPv6 address using EUI-64 method. The prefix given is 2001:db8:abcd::/64.

On R1:

R1(config-if)#ipv6 enable
R1(config-if)#ipv6 address 2001:db8:abcd::/64 eui-64

On R2:

R2(config-if)#ipv6 enable
R2(config-if)#ipv6 address 2001:db8:abcd::/64 eui-64

Now exit configuration mode and save the configuration

R1(config-if)#end
R1#write memory

R2(config-if)#end
R2#write memory

 

Verification:

Test the connectivity between the routers by pinging.

R1#ping 172.16.47.254

Use show command show ipv6 interface brief on R2 to check the EUI-64 generated address then ping from R1.

R1#ping ipv6 2001:db8:abcd::<R2-EUI-64-generated-IPv6>

 

Packet Tracer File

Clicking this button will begin the download of a ZIP file. Inside the ZIP file, you'll find a Packet Tracer Activity (.pka) file, which will automatically track your progress as you configure the network.